Snitz Forums 2000
Snitz Forums 2000
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help Groups for Snitz Forums 2000 Users
 Help: MOD Implementation
 Proeder's File Attachment Mod
 New Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

MaGraham
Senior Member

USA
1297 Posts

Posted - 27 April 2016 :  13:59:13  Show Profile  Reply with Quote
I am now on a different server (such a nightmare with hosting) and receiving the following error message when trying to upload an image within a post.


Request object error 'ASP 0104 : 80004005'

Operation not Allowed

/fp/outputFile.asp, line 71




Here are lines 66-79


Response.Expires=0
Response.Buffer = TRUE
Response.Clear

byteCount = Request.TotalBytes
RequestBin = Request.BinaryRead(byteCount)
Dim UploadRequest
Set UploadRequest = CreateObject("Scripting.Dictionary")
BuildUploadRequest RequestBin
membername = UploadRequest.Item("memberName").Item("Value")
subfolder = subfolder & "/" & membername
contentType = UploadRequest.Item("blob").Item("ContentType")
filepathname = replace(UploadRequest.Item("blob").Item("FileName"),vbNullChar,"")
filename = Right(filepathname,Len(filepathname)-InstrRev(filepathname,"\"))


Thank you for your time in looking at this!


"Do all the good you can, by all the means you can, in all the ways you can, at all the times you can, to all the people you can, as long as ever you can." - John Wesley

Carefree
Advanced Member

Philippines
4206 Posts

Posted - 27 April 2016 :  14:50:28  Show Profile
It just means your host, yet again, has left the default values of IIS untouched. This one relates to the maximum file size, specified by (AspMaxRequestEntityAllowed). Instead of relying on your host to do it, you could edit the file "web.config" as follows. The number in red (104857600) reflects the BYTE value of the largest allowed file size. Keep in mind, instead of the commonly used 1000, there are really 1024 bytes to a kilobyte, 1024 kilobytes to a megabyte, etc. 104857600 = 100 MB


Inside the <system.webserver> section, add these lines:

    <security>
         <requestFiltering>
               <requestLimits maxAllowedContentLength="104857600" />
         </requestFiltering>
    </security>


Edit: Although it's SUPPOSED to work this way, some servers which do not natively support ASP (e.g., non-Microsoft servers) don't allow the web.config file to override the default IIS settings. In those cases, the change must be made by the host using the IIS plug-in.

Edited by - Carefree on 27 April 2016 22:21:12
Go to Top of Page

MaGraham
Senior Member

USA
1297 Posts

Posted - 27 April 2016 :  15:43:02  Show Profile

That's not working, Carefree. The file may not be updating after I upload it.

See this post.


"Do all the good you can, by all the means you can, in all the ways you can, at all the times you can, to all the people you can, as long as ever you can." - John Wesley
Go to Top of Page

MaGraham
Senior Member

USA
1297 Posts

Posted - 28 April 2016 :  09:34:53  Show Profile

This is what I now think, Carefree. The problem, apparently, is that hosting has me connecting to a server that isn't secure. So when I upload files, they aren't going to the now secure website. Thus, my files are not being updated. At least to me, that seems logical.

Prayerfully, your fix will work as soon as hosting corrects the issue with the security certificate and I re-upload the edited web.config file.



Adding here: Smaller files upload without error.


"Do all the good you can, by all the means you can, in all the ways you can, at all the times you can, to all the people you can, as long as ever you can." - John Wesley

Edited by - MaGraham on 28 April 2016 10:06:59
Go to Top of Page

Webbo
Average Member

United Kingdom
982 Posts

Posted - 28 April 2016 :  17:08:02  Show Profile  Visit Webbo's Homepage
The setting is within IIS as Carefree pointed out and is something your host needs to change unless it's a dedicated server that you have access to.
The problem is if it is a shared server the hosts might not increase the limit.
Go to Top of Page

MaGraham
Senior Member

USA
1297 Posts

Posted - 26 May 2016 :  20:35:48  Show Profile

Does this error mean the same thing?

Request object -2147467259 007~ASP 0104~Operation not Allowed

Hosting is saying it's not an IIS issue.


There have been hosting issues since January!





"Do all the good you can, by all the means you can, in all the ways you can, at all the times you can, to all the people you can, as long as ever you can." - John Wesley
Go to Top of Page

Carefree
Advanced Member

Philippines
4206 Posts

Posted - 27 May 2016 :  01:55:17  Show Profile
No, that's a database path or ODBC connection issue. If you are using an ODBC driver in "config.asp" to connect your database, then it could be a host issue. Otherwise, it may be simply a matter of choosing a different method to connect.
Go to Top of Page

MaGraham
Senior Member

USA
1297 Posts

Posted - 28 May 2016 :  06:05:37  Show Profile
I can upload tiny images. Hosting told me to add the following to web.config.

AspMaxRequestEntityAllowed = "1073741824"


<security>
<requestFiltering>
<requestLimits AspMaxRequestEntityAllowed = "1073741824" />
</requestFiltering>
</security>



That was yesterday morning and I had not been to the website yet. Anyway, I added that to web.config and now only the homepage will load. The site loaded fine the night before so I don't know what hosting could have done. The webpages are completely blank.


Carefree, can you check your email?


"Do all the good you can, by all the means you can, in all the ways you can, at all the times you can, to all the people you can, as long as ever you can." - John Wesley

Edited by - MaGraham on 28 May 2016 06:08:18
Go to Top of Page

Carefree
Advanced Member

Philippines
4206 Posts

Posted - 28 May 2016 :  15:52:54  Show Profile
Your hosts aren't very good. Check your site.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic
 Printer Friendly
Jump To:
Snitz Forums 2000 © 2000-2021 Snitz™ Communications Go To Top Of Page
This page was generated in 0.22 seconds. Powered By: Snitz Forums 2000 Version 3.4.07