Snitz Forums 2000
Snitz Forums 2000
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help Groups for Snitz Forums 2000 Users
 Help: Database: MS Access
 Connection string problems
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic Next Topic  

snowbird30ds
Starting Member

United Kingdom
33 Posts

Posted - 19 November 2020 :  08:02:16  Show Profile  Reply with Quote
I'm in the process of moving server to hostgator and struggling to get a connection, I have an existing access db, which connection string should I use? Attached is a pic of the odbc options I can setup.

Eventually I hope to go over to mysql so any help with that connection would be appreciated too, I've tried all options so far with no joy.
Thanks in advance.
Here are the server specs.
Windows Server 2016
Windows IIS 10
Plesk Panel 17.5 for Windows
MSSQL Server 2016 Web Edition
MySQL Server 5.6
MySQL Connector 5.3
Access Databases 2007, 2010
ASP Classic, ASP.NET 2.0, 3.5, 4.0, 4.5, 4.6 & 4.7
PHP 5.2.17 through PHP 5.6.39, PHP 7.0.33
Python, SSI (Optional)
cURL, GD Library, MVC 2.0/3.0/4.0/5.0, AJAX
AwStats, SmarterStats
MSFTP 10.0
URL Rewrite 2.0
SmarterMail Mail Server 15

Edited by - snowbird30ds on 19 November 2020 08:21:23

HuwR
Forum Admin

United Kingdom
20550 Posts

Posted - 19 November 2020 :  08:36:13  Show Profile  Visit HuwR's Homepage  Reply with Quote
You should choose microsoft access driver, you would then use the 'connection name in the' config.asp file.

you will need to use this setting in config.asp and replace the name with the one you have created, make sure you comment out your existing connection and uncomment this one.

'strConnString = "snitz_db" '## DSN

MVC .net dev/test site | MVC .net running on Raspberry Pi
Go to Top of Page

snowbird30ds
Starting Member

United Kingdom
33 Posts

Posted - 19 November 2020 :  08:58:44  Show Profile  Reply with Quote
Thanks Huw
I tried that but keep getting:
[Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

A hunt around seems to suggest a 32/64 bit issue on the server, I have raised a ticket with them.

Edited by - snowbird30ds on 19 November 2020 11:15:22
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20550 Posts

Posted - 19 November 2020 :  18:00:41  Show Profile  Visit HuwR's Homepage  Reply with Quote
yes sounds like it, classic asp is 32 bit and they probably have 6bit drivers installed

MVC .net dev/test site | MVC .net running on Raspberry Pi
Go to Top of Page

snowbird30ds
Starting Member

United Kingdom
33 Posts

Posted - 20 November 2020 :  15:43:51  Show Profile  Reply with Quote
Found a setting in my user control panel to allow 32bit applications and it works!
Next...
I'm wanting to go over to mysql at some point and keep getting the following error when I change the config file for sql:
[MySQL][ODBC 5.3(w) Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)
The 'forum' dsn setting connects ok when I test it in my control panel, what does this mean? How do you include a password in the string? This what I am sing to get this.
strConnString = "forum" '## DSN
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20550 Posts

Posted - 21 November 2020 :  09:36:52  Show Profile  Visit HuwR's Homepage  Reply with Quote
You'll need to check with your host about that

MVC .net dev/test site | MVC .net running on Raspberry Pi
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000 © 2000-2019 Snitz™ Communications Go To Top Of Page
This page was generated in 0.05 seconds. Powered By: Snitz Forums 2000 Version 3.4.07