Snitz Forums 2000
Snitz Forums 2000
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Snitz Forums 2000 DEV-Group
 DEV Bug Reports (Open)
 SF2000 v3.4.07 - strTablePrefix misuse
 New Topic  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

PBsoft
Starting Member

Italy
5 Posts

Posted - 01 November 2009 :  04:16:26  Show Profile  Visit PBsoft's Homepage
I found several lines of code where you used strTablePrefix variable but you should use a different variable.

Here they are:

REGISTER.ASP (1 occurrency)
line 399 -> should use strFilterTablePrefix

POP_PROFILE.ASP (6 occurrencies)
line 1164 -> should use strMemberTablePrefix
line 1173 -> should use strMemberTablePrefix
line 1183 -> should use strMemberTablePrefix
line 1512 -> should use strMemberTablePrefix
line 1521 -> should use strMemberTablePrefix
line 1531 -> should use strMemberTablePrefix

SETUP.ASP (20 occurrencies)
all occurrencies are enclosed into "Setup for update 12" section and for each occurrency use you should use strMemberTablePrefix

You can advice all the previous problems only if you change strFilterTablePrefix and strMemberTablePrefix variables values at installation time (as I did).

Gabriele Bertolucci @ PBsoft

Edited by - PBsoft on 01 November 2009 04:19:11

HuwR
Forum Admin

United Kingdom
20563 Posts

Posted - 01 November 2009 :  06:29:40  Show Profile  Visit HuwR's Homepage
could you explain why you think the spam_mail table should use strmembertablePrefix in pop_profile but strfiltertable prefix in register.asp ?

that just isn't consistant
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20563 Posts

Posted - 01 November 2009 :  06:33:06  Show Profile  Visit HuwR's Homepage
I gues what your are trying to imply is that al instances of spam_mail should user strfiltertableprefix


as was reported and discussed here, please try searching before posting.
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 01 November 2009 :  12:47:28  Show Profile  Send ruirib a Yahoo! Message
The occurrences in setup.asp are being reported for the first time, so I think it's better to start a new bug report, specific to setup.asp. I have asked the user to do so.


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20563 Posts

Posted - 01 November 2009 :  13:05:42  Show Profile  Visit HuwR's Homepage
There is nothing wrong with SETUP.ASP it is actually correct, it is pop_profile/register.asp that should be fixed to use strFilterTablePrefix, as was discussed in the post I linked too.
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 01 November 2009 :  13:23:21  Show Profile  Send ruirib a Yahoo! Message
So you don't think it is a bug for the setup.asp code to use strTablePrefix sometimes and strMemberTablePrefix others? For example:

Lines#3634-3637:

SpecialSQL12(Access) = "ALTER TABLE " & strTablePrefix  & "MEMBERS ALTER COLUMN M_IP TEXT (50) "
			SpecialSQL12(SQL6) = "ALTER TABLE " & strTablePrefix  & "MEMBERS ALTER COLUMN M_IP VARCHAR (50) '000.000.000.000' "
			SpecialSQL12(SQL7) = "ALTER TABLE " & strTablePrefix  & "MEMBERS ALTER COLUMN M_IP NVARCHAR (50) '000.000.000.000' "
			SpecialSQL12(MySql) = "ALTER TABLE " & strTablePrefix & "MEMBERS MODIFY M_IP VARCHAR (50) DEFAULT '000.000.000.000' "





Lines#3736-3739:

	                SpecialSQL12(Access) = "ALTER TABLE " & strMemberTablePrefix  & "MEMBERS ADD M_ALLOWEMAIL smallint DEFAULT 0 "
			SpecialSQL12(SQL6) = "ALTER TABLE " & strMemberTablePrefix  & "MEMBERS ADD M_ALLOWEMAIL smallint DEFAULT 0 "
			SpecialSQL12(SQL7) = "ALTER TABLE " & strMemberTablePrefix  & "MEMBERS ADD M_ALLOWEMAIL smallint DEFAULT 0 "
			SpecialSQL12(MySql) = "ALTER TABLE " & strMemberTablePrefix  & "MEMBERS ADD M_ALLOWEMAIL smallint DEFAULT 0"


If the prefixes are different, doesn't it look like this will generate errors during upgrade of previous version forums?


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20563 Posts

Posted - 01 November 2009 :  13:48:36  Show Profile  Visit HuwR's Homepage
yes, sorry, it was PBSoft saying
quote:
POP_PROFILE.ASP (6 occurrencies)
line 1164 -> should use strMemberTablePrefix
line 1173 -> should use strMemberTablePrefix
line 1183 -> should use strMemberTablePrefix
line 1512 -> should use strMemberTablePrefix
line 1521 -> should use strMemberTablePrefix
line 1531 -> should use strMemberTablePrefix

that was confusing me so was just looking at occurences of the spam_mail table in setup.asp, so to be clear the lines above in pop_profile should be changed to strFilterTablePrefix, not strMemberTablePrefix and the lines in setup.asp should be strMemberTablePrefix and not strTablePrefix
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 01 November 2009 :  14:45:23  Show Profile  Send ruirib a Yahoo! Message
I suggested PBsoft to post just a bug report for setup.asp, so that it can be dealt with when we can. Hope he does it. If not, I may try to do it myself and provide a fix too, later on.


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Topic Locked
 Printer Friendly
Jump To:
Snitz Forums 2000 © 2000-2021 Snitz™ Communications Go To Top Of Page
This page was generated in 0.05 seconds. Powered By: Snitz Forums 2000 Version 3.4.07