Snitz Forums 2000
Snitz Forums 2000
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help Groups for Snitz Forums 2000 Users
 Help: Database: MS Access
 How to setup on Windows Server 2008 R2/64bits
 New Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

neerajbhatia
Starting Member

USA
4 Posts

Posted - 30 January 2012 :  10:09:07  Show Profile  Reply with Quote
How do I setup Snitz on Windows Server 2008 R2/64 bits? I am not able to find 64-bits ODBC drivers?

Thanks in advance

Podge
Support Moderator

Ireland
3775 Posts

Posted - 30 January 2012 :  10:32:18  Show Profile  Send Podge an ICQ Message  Send Podge a Yahoo! Message
From memory you have to enable 32 bit applications in your snitz website in IIS 7.5.

Podge.

The Hunger Site - Click to donate free food | My Blog | Snitz 3.4.05 AutoInstall (Beta!)

My Mods: CAPTCHA Mod | GateKeeper Mod
Tutorial: Enable subscriptions on your board

Warning: The post above or below may contain nuts.
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20448 Posts

Posted - 30 January 2012 :  10:38:51  Show Profile  Visit HuwR's Homepage
yes, pretty sure that is correct, also if you need to set up a dsn for 32bit, check out this article

http://sqlblog.com/blogs/john_paul_cook/archive/2010/03/16/32-bit-odbc-on-windows-server-2008-r2.aspx

MVC .net dev/test site
Go to Top of Page

neerajbhatia
Starting Member

USA
4 Posts

Posted - 30 January 2012 :  10:48:57  Show Profile
Thanks for your rapid response, but could you please share the exact steps with me? Where is this option available?
Go to Top of Page

neerajbhatia
Starting Member

USA
4 Posts

Posted - 30 January 2012 :  10:56:14  Show Profile
I have installed 32-bits ODBC set on this system and configured a 32-bits ODBC entry. It is not visible to my test environment.

I am using entry#6 in the config.asp file for
DRIVER={Microsoft Access Driver (*.mdb) pointing directly to the MDB file.
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20448 Posts

Posted - 30 January 2012 :  10:59:37  Show Profile  Visit HuwR's Homepage
you enable it at the application pool (not the website)

select the application pool your site is set to use (should be classic) then open advanced settings, there will be an option for 'enable 32 bit'

MVC .net dev/test site
Go to Top of Page

neerajbhatia
Starting Member

USA
4 Posts

Posted - 30 January 2012 :  13:57:24  Show Profile
Thanks again. I found the configuration setting. My forums are up and running now.
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20448 Posts

Posted - 30 January 2012 :  14:35:55  Show Profile  Visit HuwR's Homepage
glad you got it working

MVC .net dev/test site
Go to Top of Page

robbieh
Starting Member

USA
4 Posts

Posted - 21 May 2012 :  15:17:07  Show Profile  Visit robbieh's Homepage
Hello, I have a similar situation. I can get the database to work as long as the filename is left to the default of snitz_forum_2000.mdb, and the file has to be in the forum directory. Moving it out and/or changing the name, along with also changing strConnString in config.asp, does not work. As in this thread, this is on Windows Server 2008, 64 bit of course.
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20448 Posts

Posted - 21 May 2012 :  15:29:21  Show Profile  Visit HuwR's Homepage
can't think of any sane reason why changing the name of the database will make any difference whatsoever, moving it to another directory is probably a permission issue.

Are you getting an error message? if so what is it?

MVC .net dev/test site
Go to Top of Page

robbieh
Starting Member

USA
4 Posts

Posted - 13 July 2012 :  15:13:13  Show Profile  Visit robbieh's Homepage
I haven't had time to work on my forum in forever. But today, I have some time.

Right now the forum will almost work as long as everything is on the C: drive, 32 bit is enabled in the application pool, and the database is in the forum folder with the default name. BUT, when I click on a topic, it crashes. Whether it is this error, or the error that occurs when I try to move it or rename the database, it is always this:

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

I really want to keep running Snitz since it's ASP based and should run on my IIS Server.

Here's the URL:
http://www.dallassecretwine.com/forum/default.asp

Edited by - robbieh on 13 July 2012 15:13:55
Go to Top of Page

robbieh
Starting Member

USA
4 Posts

Posted - 13 July 2012 :  15:19:08  Show Profile  Visit robbieh's Homepage
I believe this error is related.

Log Name: Application
Source: ASP.NET 4.0.30319.0
Date: 7/13/2012 2:17:17 PM
Event ID: 1309
Task Category: Web Event
Level: Warning
Keywords: Classic
User: N/A
Computer: SERVER
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 7/13/2012 2:17:17 PM
Event time (UTC): 7/13/2012 7:17:17 PM
Event ID: c4d843e9a7d74535971e85d93e8cc0cc
Event sequence: 7
Event occurrence: 4
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/Connect-1-129866789591734665
Trust level: Full
Application Virtual Path: /Connect
Application Path: C:\Program Files\Windows Server\Bin\WebApps\Client\
Machine name: SERVER

Process information:
Process ID: 9452
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: FileNotFoundException
Exception message: Could not load file or assembly 'SetupCommon, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
at Microsoft.WindowsServerSolutions.Client.Website.Global.Application_BeginRequest(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)



Request information:
Request URL: https://SERVER:65515/connect/default.aspx?get=VersionInfo.xml&LanguageId=1033&64bit=1
Request path: /connect/default.aspx
User host address: fe80::f576:764b:dcb4:8560/Connect
User:
Is authenticated: False
Authentication Type:
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 23
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at Microsoft.WindowsServerSolutions.Client.Website.Global.Application_BeginRequest(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Custom event details:

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="ASP.NET 4.0.30319.0" />
<EventID Qualifiers="32768">1309</EventID>
<Level>3</Level>
<Task>3</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-07-13T19:17:17.000000000Z" />
<EventRecordID>15469</EventRecordID>
<Channel>Application</Channel>
<Computer>SERVER</Computer>
<Security />
</System>
<EventData>
<Data>3005</Data>
<Data>An unhandled exception has occurred.</Data>
<Data>7/13/2012 2:17:17 PM</Data>
<Data>7/13/2012 7:17:17 PM</Data>
<Data>c4d843e9a7d74535971e85d93e8cc0cc</Data>
<Data>7</Data>
<Data>4</Data>
<Data>0</Data>
<Data>/LM/W3SVC/1/ROOT/Connect-1-129866789591734665</Data>
<Data>Full</Data>
<Data>/Connect</Data>
<Data>C:\Program Files\Windows Server\Bin\WebApps\Client\</Data>
<Data>SERVER</Data>
<Data>
</Data>
<Data>9452</Data>
<Data>w3wp.exe</Data>
<Data>NT AUTHORITY\NETWORK SERVICE</Data>
<Data>FileNotFoundException</Data>
<Data>Could not load file or assembly 'SetupCommon, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
at Microsoft.WindowsServerSolutions.Client.Website.Global.Application_BeginRequest(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

</Data>
<Data>https://SERVER:65515/connect/default.aspx?get=VersionInfo.xml&LanguageId=1033&64bit=1</Data>
<Data>/connect/default.aspx</Data>
<Data>fe80::f576:764b:dcb4:8560%11</Data>
<Data>
</Data>
<Data>False</Data>
<Data>
</Data>
<Data>NT AUTHORITY\NETWORK SERVICE</Data>
<Data>23</Data>
<Data>NT AUTHORITY\NETWORK SERVICE</Data>
<Data>False</Data>
<Data> at Microsoft.WindowsServerSolutions.Client.Website.Global.Application_BeginRequest(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
</Data>
</EventData>
</Event>
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic
 Printer Friendly
Jump To:
Snitz Forums 2000 © 2000-2019 Snitz™ Communications Go To Top Of Page
This page was generated in 0.12 seconds. Powered By: Snitz Forums 2000 Version 3.4.07