Snitz Forums 2000
Snitz Forums 2000
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help Groups for Snitz Forums 2000 Users
 Help: Database: MySql
 13 errors from setup.asp
 New Topic  Topic Locked
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

marckmcgill
Junior Member

Italy
134 Posts

Posted - 28 January 2010 :  04:56:22  Show Profile
Good morning everybody. We are trying to convert from Access to
mySQL, so as a first step I've read on other threads that an empty
but working mySQL database with all tables must be setup first.

That's what I'm trying to do. The database has been created and the
connection string works. However, when I call setup.asp to have it
create the tables, 13 "critical errors" are reported and the setup
process is declared as "not completed".

Does anyone know why this may happen and what I can do to fix it? I'm
trying to copy here below the table reported by deafault.asp, hoping
it will be readable. Thank you very much.



Please Wait until the installation has been completed !
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'CAT_ID'
strSql: CREATE TABLE FORUM_CATEGORY ( CAT_ID INT (11) DEFAULT '' NOT NULL auto_increment, CAT_STATUS SMALLINT (6) DEFAULT '1' NOT NULL , CAT_NAME VARCHAR (100) DEFAULT '', CAT_MODERATION int (11) DEFAULT '0', CAT_SUBSCRIPTION int (11) DEFAULT '0', CAT_ORDER int (11) DEFAULT '1', PRIMARY KEY (CAT_ID), KEY FORUM_CATEGORY_CAT_ID(CAT_ID), KEY FORUM_CATEGORY_CAT_STATUS (CAT_STATUS) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'FORUM_ID'
strSql: CREATE TABLE FORUM_FORUM ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID smallint (6) DEFAULT '0' NOT NULL auto_increment, F_STATUS smallint (6) DEFAULT '1', F_MAIL smallint (6) DEFAULT '1' , F_SUBJECT VARCHAR (100) DEFAULT '' , F_URL VARCHAR (255) DEFAULT '' , F_DESCRIPTION TEXT DEFAULT '' , F_TOPICS int (11) DEFAULT '0' , F_COUNT int (11) DEFAULT '0' , F_LAST_POST VARCHAR (14) DEFAULT '' , F_PASSWORD_NEW VARCHAR (255) DEFAULT '' , F_PRIVATEFORUMS int (11) DEFAULT '0' , F_TYPE smallint (6) DEFAULT '0' , F_IP VARCHAR (15) DEFAULT '000.000.000.000' , F_LAST_POST_AUTHOR int (11) DEFAULT '1' , F_LAST_POST_TOPIC_ID int (11) DEFAULT '0' , F_LAST_POST_REPLY_ID int (11) DEFAULT '0' , F_MODERATION int (11) DEFAULT '0', F_SUBSCRIPTION int (11) DEFAULT '0' , F_ORDER int (11) DEFAULT '1' , F_DEFAULTDAYS int (11) DEFAULT '30' , F_COUNT_M_POSTS smallint (6) DEFAULT '1' , F_L_ARCHIVE VARCHAR (14) DEFAULT '' , F_ARCHIVE_SCHED int (11) DEFAULT '30' , F_L_DELETE VARCHAR (14) DEFAULT '' , F_DELETE_SCHED int (11) DEFAULT '365' , F_A_TOPICS int (11) DEFAULT '0' , F_A_COUNT int (11) DEFAULT '0' , PRIMARY KEY (CAT_ID, FORUM_ID), KEY FORUM_FORUM_FORUM_ID(FORUM_ID), KEY FORUM_FORUM_CAT_ID(CAT_ID))
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MEMBER_ID'
strSql: CREATE TABLE FORUM_MEMBERS ( MEMBER_ID int (11) DEFAULT '' NOT NULL AUTO_INCREMENT, M_STATUS smallint (6) DEFAULT '0' , M_NAME VARCHAR (75) DEFAULT '' , M_USERNAME VARCHAR (150) DEFAULT '' , M_PASSWORD VARCHAR (65) DEFAULT '' , M_EMAIL VARCHAR (50) DEFAULT '' , M_COUNTRY VARCHAR (50) DEFAULT '' , M_HOMEPAGE VARCHAR (255) DEFAULT '' , M_SIG TEXT DEFAULT '' , M_VIEW_SIG smallint (6) NULL DEFAULT '1' , M_SIG_DEFAULT smallint (6) NULL DEFAULT '1' , M_DEFAULT_VIEW int (11) DEFAULT '1' , M_LEVEL smallint (6) DEFAULT '1' , M_AIM VARCHAR (150) DEFAULT '' , M_ICQ VARCHAR (150) DEFAULT '' , M_MSN VARCHAR (150) DEFAULT '' , M_YAHOO VARCHAR (150) DEFAULT '' , M_POSTS int (11) DEFAULT '0' , M_DATE VARCHAR (14) DEFAULT '' , M_LASTHEREDATE VARCHAR (14) DEFAULT '' , M_LASTPOSTDATE VARCHAR (14) DEFAULT '' , M_TITLE VARCHAR (50) DEFAULT '' , M_SUBSCRIPTION smallint (6) DEFAULT '0' , M_HIDE_EMAIL smallint (6) DEFAULT '0' , M_RECEIVE_EMAIL smallint (6) DEFAULT '1' , M_LAST_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_FIRSTNAME VARCHAR (100) DEFAULT '' , M_LASTNAME VARCHAR (100) DEFAULT '' , M_OCCUPATION VARCHAR (255) DEFAULT '' , M_SEX VARCHAR (50) DEFAULT '' , M_AGE VARCHAR (10) DEFAULT '' , M_DOB VARCHAR (8) DEFAULT '' , M_HOBBIES TEXT DEFAULT '' , M_LNEWS TEXT DEFAULT '' , M_QUOTE TEXT DEFAULT '' , M_BIO TEXT DEFAULT '' , M_MARSTATUS VARCHAR (100) DEFAULT '' , M_LINK1 VARCHAR (255) DEFAULT '' , M_LINK2 VARCHAR (255) DEFAULT '' , M_CITY VARCHAR (100) DEFAULT '' , M_STATE VARCHAR (100) DEFAULT '' , M_PHOTO_URL VARCHAR (255) DEFAULT '' , M_KEY VARCHAR (32) DEFAULT '' , M_NEWEMAIL VARCHAR (50) DEFAULT '', M_PWKEY VARCHAR (32) DEFAULT '' , M_SHA256 smallint (6) DEFAULT '1' ,PRIMARY KEY (MEMBER_ID), KEY FORUM_MEMBERS_MEMBER_ID (MEMBER_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MEMBER_ID'
strSql: CREATE TABLE FORUM_MEMBERS_PENDING ( MEMBER_ID int (11) DEFAULT '' NOT NULL AUTO_INCREMENT, M_STATUS smallint (6) DEFAULT '0' , M_NAME VARCHAR (75) DEFAULT '' , M_USERNAME VARCHAR (150) DEFAULT '' , M_PASSWORD VARCHAR (65) DEFAULT '' , M_EMAIL VARCHAR (50) DEFAULT '' , M_COUNTRY VARCHAR (50) DEFAULT '' , M_HOMEPAGE VARCHAR (255) DEFAULT '' , M_SIG TEXT DEFAULT '' , M_VIEW_SIG smallint (6) NULL DEFAULT '1' , M_SIG_DEFAULT smallint (6) NULL DEFAULT '1' , M_DEFAULT_VIEW int (11) DEFAULT '1' , M_LEVEL smallint (6) DEFAULT '1' , M_AIM VARCHAR (150) DEFAULT '' , M_ICQ VARCHAR (150) DEFAULT '' , M_MSN VARCHAR (150) DEFAULT '' , M_YAHOO VARCHAR (150) DEFAULT '' , M_POSTS int (11) DEFAULT '0' , M_DATE VARCHAR (14) DEFAULT '' , M_LASTHEREDATE VARCHAR (14) DEFAULT '' , M_LASTPOSTDATE VARCHAR (14) DEFAULT '' , M_TITLE VARCHAR (50) DEFAULT '' , M_SUBSCRIPTION smallint (6) DEFAULT '0' , M_HIDE_EMAIL smallint (6) DEFAULT '0' , M_RECEIVE_EMAIL smallint (6) DEFAULT '1' , M_LAST_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_FIRSTNAME VARCHAR (100) DEFAULT '' , M_LASTNAME VARCHAR (100) DEFAULT '' , M_OCCUPATION VARCHAR (255) DEFAULT '' , M_SEX VARCHAR (50) DEFAULT '' , M_AGE VARCHAR (10) DEFAULT '' , M_DOB VARCHAR (8) DEFAULT '' , M_HOBBIES TEXT DEFAULT '' , M_LNEWS TEXT DEFAULT '' , M_QUOTE TEXT DEFAULT '' , M_BIO TEXT DEFAULT '' , M_MARSTATUS VARCHAR (100) DEFAULT '' , M_LINK1 VARCHAR (255) DEFAULT '' , M_LINK2 VARCHAR (255) DEFAULT '' , M_CITY VARCHAR (100) DEFAULT '' , M_STATE VARCHAR (100) DEFAULT '' , M_PHOTO_URL VARCHAR (255) DEFAULT '' , M_KEY VARCHAR (32) DEFAULT '' , M_NEWEMAIL VARCHAR (50) DEFAULT '', M_PWKEY VARCHAR (32) DEFAULT '' , M_APPROVE smallint (6) DEFAULT '' , M_SHA256 smallint (6) DEFAULT '1' , PRIMARY KEY (MEMBER_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MOD_ID'
strSql: CREATE TABLE FORUM_MODERATOR ( MOD_ID int (11) DEFAULT '' NOT NULL auto_increment, FORUM_ID int (11) DEFAULT '1' , MEMBER_ID int (11) DEFAULT '1' , MOD_TYPE smallint (6) DEFAULT '0', PRIMARY KEY (MOD_ID))
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'REPLY_ID'
strSql: CREATE TABLE FORUM_REPLY ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID int (11) DEFAULT '1' NOT NULL , TOPIC_ID int (11) DEFAULT '1' NOT NULL , REPLY_ID int (11) DEFAULT '' NOT NULL auto_increment, R_MAIL smallint (6) DEFAULT '0' , R_AUTHOR int (11) DEFAULT '1' , R_MESSAGE text , R_DATE VARCHAR (14) DEFAULT '' , R_IP VARCHAR (15) DEFAULT '000.000.000.000', R_STATUS smallint (6) DEFAULT '0', R_LAST_EDIT VARCHAR (14) , R_LAST_EDITBY int (11) , R_SIG smallint (6) DEFAULT '0', PRIMARY KEY (CAT_ID, FORUM_ID, TOPIC_ID, REPLY_ID), KEY FORUM_REPLY_CATFORTOPREPL(CAT_ID,FORUM_ID,TOPIC_ID, REPLY_ID), KEY FORUM_REPLY_REP_ID(REPLY_ID), KEY FORUM_REPLY_CAT_ID(CAT_ID), KEY FORUM_REPLY_FORUM_ID(FORUM_ID), KEY FORUM_REPLY_TOPIC_ID (TOPIC_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'TOPIC_ID'
strSql: CREATE TABLE FORUM_TOPICS ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID int (11) DEFAULT '1' NOT NULL , TOPIC_ID int (11) DEFAULT '' NOT NULL auto_increment, T_STATUS smallint (6) DEFAULT '1' , T_MAIL smallint (6) DEFAULT '0' , T_SUBJECT VARCHAR (100) DEFAULT '' , T_MESSAGE text , T_AUTHOR int (11) DEFAULT '1' , T_REPLIES int (11) DEFAULT '0' , T_UREPLIES int (11) DEFAULT '0' , T_VIEW_COUNT int (11) DEFAULT '0' , T_LAST_POST VARCHAR (14) DEFAULT '' , T_DATE VARCHAR (14) DEFAULT '', T_LAST_POSTER int (11) DEFAULT '1', T_IP VARCHAR (15) DEFAULT '000.000.000.000', T_LAST_POST_AUTHOR int (11) DEFAULT '1', T_LAST_POST_REPLY_ID int (11) DEFAULT '0', T_ARCHIVE_FLAG int (11) DEFAULT '1', T_LAST_EDIT VARCHAR (14) , T_LAST_EDITBY int (11) , T_STICKY smallint (6) DEFAULT '0', T_SIG smallint (6) DEFAULT '0', PRIMARY KEY (CAT_ID, FORUM_ID, TOPIC_ID), KEY FORUM_TOPIC_CATFORTOP(CAT_ID,FORUM_ID,TOPIC_ID), KEY FORUM_TOPIC_CAT_ID(CAT_ID), KEY FORUM_TOPIC_FORUM_ID(FORUM_ID), KEY FORUM_TOPIC_TOPIC_ID (TOPIC_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'COUNT_ID'
strSql: CREATE TABLE FORUM_TOTALS ( COUNT_ID smallint (6) DEFAULT '' NOT NULL auto_increment, P_COUNT int (11) DEFAULT '0' , T_COUNT int (11) DEFAULT '0' , P_A_COUNT int (11) DEFAULT '0' , T_A_COUNT int (11) DEFAULT '0' , U_COUNT int (11) DEFAULT '0' , PRIMARY KEY (COUNT_ID), KEY FORUM_TOTALS_COUNT_ID (COUNT_ID) )
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_CATEGORY' doesn't exist
strSql: INSERT INTO FORUM_CATEGORY(CAT_STATUS, CAT_NAME) VALUES(1, 'Snitz Forums 2000')
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_MEMBERS' doesn't exist
strSql: INSERT INTO FORUM_MEMBERS (M_STATUS, M_NAME, M_USERNAME, M_PASSWORD, M_EMAIL, M_COUNTRY, M_HOMEPAGE, M_LINK1, M_LINK2, M_PHOTO_URL, M_SIG, M_VIEW_SIG, M_DEFAULT_VIEW, M_LEVEL, M_AIM, M_ICQ, M_MSN, M_YAHOO, M_POSTS, M_DATE, M_LASTHEREDATE, M_LASTPOSTDATE, M_TITLE, M_SUBSCRIPTION, M_HIDE_EMAIL, M_RECEIVE_EMAIL, M_LAST_IP, M_IP) VALUES(1, 'highinfidelity', 'highinfidelity', '8d3e0bf685d077784de23e1c217de5c5d8da4c0200d7c86df6ff607d9cbc6959', 'yourmail@server.com', ' ', ' ', ' ', ' ', ' ', ' ', 1, 1, 3, ' ', ' ', ' ', ' ', 1, '20100128044359', '20100128043859', '20100128044359', 'Forum Admin', '0', '0', 1, '000.000.000.000', '000.000.000.000')
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_FORUM' doesn't exist
strSql: INSERT INTO FORUM_FORUM(CAT_ID, F_STATUS, F_MAIL, F_SUBJECT, F_URL, F_DESCRIPTION, F_TOPICS, F_COUNT, F_LAST_POST, F_PASSWORD_NEW, F_PRIVATEFORUMS, F_TYPE, F_IP, F_LAST_POST_AUTHOR, F_LAST_POST_TOPIC_ID, F_LAST_POST_REPLY_ID) VALUES(1, 1, '0', 'Testing Forums', '', 'This forum gives you a chance to become more familiar with how this product responds to different features and keeps testing in one place instead of posting tests all over. Happy Posting! ', 1, 1, '20100128044359', '', '0', '0', '000.000.000.000', 1, 1, 0)
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_TOPICS' doesn't exist
strSql: INSERT INTO FORUM_TOPICS (CAT_ID, FORUM_ID, T_STATUS, T_MAIL, T_SUBJECT, T_MESSAGE, T_AUTHOR, T_REPLIES, T_UREPLIES, T_VIEW_COUNT, T_LAST_POST, T_DATE, T_LAST_POSTER, T_IP, T_LAST_POST_AUTHOR, T_LAST_POST_REPLY_ID, T_ARCHIVE_FLAG) VALUES(1, 1, 1, '0', 'Welcome to Snitz Forums 2000', 'Thank you for downloading the Snitz Forums 2000. We hope you enjoy this great tool to support your organization! Many thanks go out to John Penfold <asp@asp-dev.com> and Tim Teal <tteal@tealnet.com> for the original source code and to all the people of Snitz Forums 2000 at http://forum.snitz.com for continued support of this product.', 1, '0', '0', '0', '20100128044359', '20100128044359', '0', '000.000.000.000', 1, 0, 1)
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_TOTALS' doesn't exist
strSql: INSERT INTO FORUM_TOTALS (COUNT_ID, P_COUNT, T_COUNT, U_COUNT) VALUES(1,1,1,1)

The Installation has NOT been completed !

There were 13 Critical Errors...

Click here to retry....

Click here to check the Database....

Edited by - AnonJr on 28 January 2010 10:07:41

AnonJr
Moderator

United States
5768 Posts

Posted - 28 January 2010 :  10:09:43  Show Profile  Visit AnonJr's Homepage
First, which version of the forum are you using?

Have you done a search on this particular error code? I seem to remember there was a fix for this posted earlier, and I could have sworn that it was incorporated into 3.4.06... or maybe it was 3.4.07.
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 28 January 2010 :  13:06:07  Show Profile  Send ruirib a Yahoo! Message
Really the issue is your current forum version. For 3.4.07 the creation code specifies the default values for the int fields correctly. If not, then you will have to edit inc_create_forum_mysql.asp so that default values for int fields are changed from '' into '0'.


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 29 January 2010 :  03:56:55  Show Profile
Hello and thanks for your replies. I made the correction suggested, now the same exact errors in the exact same places are reported but the error sentence has changed to "Invalid default value for (...)". Perhaps '1' has to be written instead of '0'?

Sorry if I insist, but I MUST address this problem rather than simply taking inc_create_forum from an updated installation because quite obviously I will have similar problems with all of the MODs.

For the records, our version is 3.4.03.

Thank you very much.
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 29 January 2010 :  04:16:16  Show Profile  Send ruirib a Yahoo! Message
You will have to actually write the whole error message. '0' is a perfectly valid default value.


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20584 Posts

Posted - 29 January 2010 :  04:35:45  Show Profile  Visit HuwR's Homepage
isn't the issue that it is trying to give a default value for something that is an auto_increment type, surely bey definition an aut inc field does not have a default. Should'nt the DEFAULT '' just be removed ?

I'm no MySQL expert so that is just a guess
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 29 January 2010 :  05:29:41  Show Profile

Please Wait until the installation has been completed !
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'CAT_ID'
strSql: CREATE TABLE FORUM_CATEGORY ( CAT_ID INT (11) DEFAULT '0' NOT NULL auto_increment, CAT_STATUS SMALLINT (6) DEFAULT '1' NOT NULL , CAT_NAME VARCHAR (100) DEFAULT '', CAT_MODERATION int (11) DEFAULT '0', CAT_SUBSCRIPTION int (11) DEFAULT '0', CAT_ORDER int (11) DEFAULT '1', PRIMARY KEY (CAT_ID), KEY FORUM_CATEGORY_CAT_ID(CAT_ID), KEY FORUM_CATEGORY_CAT_STATUS (CAT_STATUS) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'FORUM_ID'
strSql: CREATE TABLE FORUM_FORUM ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID smallint (6) DEFAULT '0' NOT NULL auto_increment, F_STATUS smallint (6) DEFAULT '1', F_MAIL smallint (6) DEFAULT '1' , F_SUBJECT VARCHAR (100) DEFAULT '' , F_URL VARCHAR (255) DEFAULT '' , F_DESCRIPTION TEXT DEFAULT '' , F_TOPICS int (11) DEFAULT '0' , F_COUNT int (11) DEFAULT '0' , F_LAST_POST VARCHAR (14) DEFAULT '' , F_PASSWORD_NEW VARCHAR (255) DEFAULT '' , F_PRIVATEFORUMS int (11) DEFAULT '0' , F_TYPE smallint (6) DEFAULT '0' , F_IP VARCHAR (15) DEFAULT '000.000.000.000' , F_LAST_POST_AUTHOR int (11) DEFAULT '1' , F_LAST_POST_TOPIC_ID int (11) DEFAULT '0' , F_LAST_POST_REPLY_ID int (11) DEFAULT '0' , F_MODERATION int (11) DEFAULT '0', F_SUBSCRIPTION int (11) DEFAULT '0' , F_ORDER int (11) DEFAULT '1' , F_DEFAULTDAYS int (11) DEFAULT '30' , F_COUNT_M_POSTS smallint (6) DEFAULT '1' , F_L_ARCHIVE VARCHAR (14) DEFAULT '' , F_ARCHIVE_SCHED int (11) DEFAULT '30' , F_L_DELETE VARCHAR (14) DEFAULT '' , F_DELETE_SCHED int (11) DEFAULT '365' , F_A_TOPICS int (11) DEFAULT '0' , F_A_COUNT int (11) DEFAULT '0' , PRIMARY KEY (CAT_ID, FORUM_ID), KEY FORUM_FORUM_FORUM_ID(FORUM_ID), KEY FORUM_FORUM_CAT_ID(CAT_ID))
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MEMBER_ID'
strSql: CREATE TABLE FORUM_MEMBERS ( MEMBER_ID int (11) DEFAULT '0' NOT NULL AUTO_INCREMENT, M_STATUS smallint (6) DEFAULT '0' , M_NAME VARCHAR (75) DEFAULT '' , M_USERNAME VARCHAR (150) DEFAULT '' , M_PASSWORD VARCHAR (65) DEFAULT '' , M_EMAIL VARCHAR (50) DEFAULT '' , M_COUNTRY VARCHAR (50) DEFAULT '' , M_HOMEPAGE VARCHAR (255) DEFAULT '' , M_SIG TEXT DEFAULT '' , M_VIEW_SIG smallint (6) NULL DEFAULT '1' , M_SIG_DEFAULT smallint (6) NULL DEFAULT '1' , M_DEFAULT_VIEW int (11) DEFAULT '1' , M_LEVEL smallint (6) DEFAULT '1' , M_AIM VARCHAR (150) DEFAULT '' , M_ICQ VARCHAR (150) DEFAULT '' , M_MSN VARCHAR (150) DEFAULT '' , M_YAHOO VARCHAR (150) DEFAULT '' , M_POSTS int (11) DEFAULT '0' , M_DATE VARCHAR (14) DEFAULT '' , M_LASTHEREDATE VARCHAR (14) DEFAULT '' , M_LASTPOSTDATE VARCHAR (14) DEFAULT '' , M_TITLE VARCHAR (50) DEFAULT '' , M_SUBSCRIPTION smallint (6) DEFAULT '0' , M_HIDE_EMAIL smallint (6) DEFAULT '0' , M_RECEIVE_EMAIL smallint (6) DEFAULT '1' , M_LAST_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_FIRSTNAME VARCHAR (100) DEFAULT '' , M_LASTNAME VARCHAR (100) DEFAULT '' , M_OCCUPATION VARCHAR (255) DEFAULT '' , M_SEX VARCHAR (50) DEFAULT '' , M_AGE VARCHAR (10) DEFAULT '' , M_DOB VARCHAR (8) DEFAULT '' , M_HOBBIES TEXT DEFAULT '' , M_LNEWS TEXT DEFAULT '' , M_QUOTE TEXT DEFAULT '' , M_BIO TEXT DEFAULT '' , M_MARSTATUS VARCHAR (100) DEFAULT '' , M_LINK1 VARCHAR (255) DEFAULT '' , M_LINK2 VARCHAR (255) DEFAULT '' , M_CITY VARCHAR (100) DEFAULT '' , M_STATE VARCHAR (100) DEFAULT '' , M_PHOTO_URL VARCHAR (255) DEFAULT '' , M_KEY VARCHAR (32) DEFAULT '' , M_NEWEMAIL VARCHAR (50) DEFAULT '', M_PWKEY VARCHAR (32) DEFAULT '' , M_SHA256 smallint (6) DEFAULT '1' ,PRIMARY KEY (MEMBER_ID), KEY FORUM_MEMBERS_MEMBER_ID (MEMBER_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MEMBER_ID'
strSql: CREATE TABLE FORUM_MEMBERS_PENDING ( MEMBER_ID int (11) DEFAULT '0' NOT NULL AUTO_INCREMENT, M_STATUS smallint (6) DEFAULT '0' , M_NAME VARCHAR (75) DEFAULT '' , M_USERNAME VARCHAR (150) DEFAULT '' , M_PASSWORD VARCHAR (65) DEFAULT '' , M_EMAIL VARCHAR (50) DEFAULT '' , M_COUNTRY VARCHAR (50) DEFAULT '' , M_HOMEPAGE VARCHAR (255) DEFAULT '' , M_SIG TEXT DEFAULT '' , M_VIEW_SIG smallint (6) NULL DEFAULT '1' , M_SIG_DEFAULT smallint (6) NULL DEFAULT '1' , M_DEFAULT_VIEW int (11) DEFAULT '1' , M_LEVEL smallint (6) DEFAULT '1' , M_AIM VARCHAR (150) DEFAULT '' , M_ICQ VARCHAR (150) DEFAULT '' , M_MSN VARCHAR (150) DEFAULT '' , M_YAHOO VARCHAR (150) DEFAULT '' , M_POSTS int (11) DEFAULT '0' , M_DATE VARCHAR (14) DEFAULT '' , M_LASTHEREDATE VARCHAR (14) DEFAULT '' , M_LASTPOSTDATE VARCHAR (14) DEFAULT '' , M_TITLE VARCHAR (50) DEFAULT '' , M_SUBSCRIPTION smallint (6) DEFAULT '0' , M_HIDE_EMAIL smallint (6) DEFAULT '0' , M_RECEIVE_EMAIL smallint (6) DEFAULT '1' , M_LAST_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_IP VARCHAR (15) DEFAULT '000.000.000.000' , M_FIRSTNAME VARCHAR (100) DEFAULT '' , M_LASTNAME VARCHAR (100) DEFAULT '' , M_OCCUPATION VARCHAR (255) DEFAULT '' , M_SEX VARCHAR (50) DEFAULT '' , M_AGE VARCHAR (10) DEFAULT '' , M_DOB VARCHAR (8) DEFAULT '' , M_HOBBIES TEXT DEFAULT '' , M_LNEWS TEXT DEFAULT '' , M_QUOTE TEXT DEFAULT '' , M_BIO TEXT DEFAULT '' , M_MARSTATUS VARCHAR (100) DEFAULT '' , M_LINK1 VARCHAR (255) DEFAULT '' , M_LINK2 VARCHAR (255) DEFAULT '' , M_CITY VARCHAR (100) DEFAULT '' , M_STATE VARCHAR (100) DEFAULT '' , M_PHOTO_URL VARCHAR (255) DEFAULT '' , M_KEY VARCHAR (32) DEFAULT '' , M_NEWEMAIL VARCHAR (50) DEFAULT '', M_PWKEY VARCHAR (32) DEFAULT '' , M_APPROVE smallint (6) DEFAULT '' , M_SHA256 smallint (6) DEFAULT '1' , PRIMARY KEY (MEMBER_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'MOD_ID'
strSql: CREATE TABLE FORUM_MODERATOR ( MOD_ID int (11) DEFAULT '0' NOT NULL auto_increment, FORUM_ID int (11) DEFAULT '1' , MEMBER_ID int (11) DEFAULT '1' , MOD_TYPE smallint (6) DEFAULT '0', PRIMARY KEY (MOD_ID))
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'REPLY_ID'
strSql: CREATE TABLE FORUM_REPLY ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID int (11) DEFAULT '1' NOT NULL , TOPIC_ID int (11) DEFAULT '1' NOT NULL , REPLY_ID int (11) DEFAULT '0' NOT NULL auto_increment, R_MAIL smallint (6) DEFAULT '0' , R_AUTHOR int (11) DEFAULT '1' , R_MESSAGE text , R_DATE VARCHAR (14) DEFAULT '' , R_IP VARCHAR (15) DEFAULT '000.000.000.000', R_STATUS smallint (6) DEFAULT '0', R_LAST_EDIT VARCHAR (14) , R_LAST_EDITBY int (11) , R_SIG smallint (6) DEFAULT '0', PRIMARY KEY (CAT_ID, FORUM_ID, TOPIC_ID, REPLY_ID), KEY FORUM_REPLY_CATFORTOPREPL(CAT_ID,FORUM_ID,TOPIC_ID, REPLY_ID), KEY FORUM_REPLY_REP_ID(REPLY_ID), KEY FORUM_REPLY_CAT_ID(CAT_ID), KEY FORUM_REPLY_FORUM_ID(FORUM_ID), KEY FORUM_REPLY_TOPIC_ID (TOPIC_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'TOPIC_ID'
strSql: CREATE TABLE FORUM_TOPICS ( CAT_ID int (11) DEFAULT '1' NOT NULL , FORUM_ID int (11) DEFAULT '1' NOT NULL , TOPIC_ID int (11) DEFAULT '0' NOT NULL auto_increment, T_STATUS smallint (6) DEFAULT '1' , T_MAIL smallint (6) DEFAULT '0' , T_SUBJECT VARCHAR (100) DEFAULT '' , T_MESSAGE text , T_AUTHOR int (11) DEFAULT '1' , T_REPLIES int (11) DEFAULT '0' , T_UREPLIES int (11) DEFAULT '0' , T_VIEW_COUNT int (11) DEFAULT '0' , T_LAST_POST VARCHAR (14) DEFAULT '' , T_DATE VARCHAR (14) DEFAULT '', T_LAST_POSTER int (11) DEFAULT '1', T_IP VARCHAR (15) DEFAULT '000.000.000.000', T_LAST_POST_AUTHOR int (11) DEFAULT '1', T_LAST_POST_REPLY_ID int (11) DEFAULT '0', T_ARCHIVE_FLAG int (11) DEFAULT '1', T_LAST_EDIT VARCHAR (14) , T_LAST_EDITBY int (11) , T_STICKY smallint (6) DEFAULT '0', T_SIG smallint (6) DEFAULT '0', PRIMARY KEY (CAT_ID, FORUM_ID, TOPIC_ID), KEY FORUM_TOPIC_CATFORTOP(CAT_ID,FORUM_ID,TOPIC_ID), KEY FORUM_TOPIC_CAT_ID(CAT_ID), KEY FORUM_TOPIC_FORUM_ID(FORUM_ID), KEY FORUM_TOPIC_TOPIC_ID (TOPIC_ID) )
Error: -2147217871 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Invalid default value for 'COUNT_ID'
strSql: CREATE TABLE FORUM_TOTALS ( COUNT_ID smallint (6) DEFAULT '0' NOT NULL auto_increment, P_COUNT int (11) DEFAULT '0' , T_COUNT int (11) DEFAULT '0' , P_A_COUNT int (11) DEFAULT '0' , T_A_COUNT int (11) DEFAULT '0' , U_COUNT int (11) DEFAULT '0' , PRIMARY KEY (COUNT_ID), KEY FORUM_TOTALS_COUNT_ID (COUNT_ID) )
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_CATEGORY' doesn't exist
strSql: INSERT INTO FORUM_CATEGORY(CAT_STATUS, CAT_NAME) VALUES(1, 'Snitz Forums 2000')
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_MEMBERS' doesn't exist
strSql: INSERT INTO FORUM_MEMBERS (M_STATUS, M_NAME, M_USERNAME, M_PASSWORD, M_EMAIL, M_COUNTRY, M_HOMEPAGE, M_LINK1, M_LINK2, M_PHOTO_URL, M_SIG, M_VIEW_SIG, M_DEFAULT_VIEW, M_LEVEL, M_AIM, M_ICQ, M_MSN, M_YAHOO, M_POSTS, M_DATE, M_LASTHEREDATE, M_LASTPOSTDATE, M_TITLE, M_SUBSCRIPTION, M_HIDE_EMAIL, M_RECEIVE_EMAIL, M_LAST_IP, M_IP) VALUES(1, 'highinfidelity', 'highinfidelity', '8d3e0bf685d077784de23e1c217de5c5d8da4c0200d7c86df6ff607d9cbc6959', 'yourmail@server.com', ' ', ' ', ' ', ' ', ' ', ' ', 1, 1, 3, ' ', ' ', ' ', ' ', 1, '20100129052717', '20100129052217', '20100129052717', 'Forum Admin', '0', '0', 1, '000.000.000.000', '000.000.000.000')
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_FORUM' doesn't exist
strSql: INSERT INTO FORUM_FORUM(CAT_ID, F_STATUS, F_MAIL, F_SUBJECT, F_URL, F_DESCRIPTION, F_TOPICS, F_COUNT, F_LAST_POST, F_PASSWORD_NEW, F_PRIVATEFORUMS, F_TYPE, F_IP, F_LAST_POST_AUTHOR, F_LAST_POST_TOPIC_ID, F_LAST_POST_REPLY_ID) VALUES(1, 1, '0', 'Testing Forums', '', 'This forum gives you a chance to become more familiar with how this product responds to different features and keeps testing in one place instead of posting tests all over. Happy Posting! ', 1, 1, '20100129052717', '', '0', '0', '000.000.000.000', 1, 1, 0)
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_TOPICS' doesn't exist
strSql: INSERT INTO FORUM_TOPICS (CAT_ID, FORUM_ID, T_STATUS, T_MAIL, T_SUBJECT, T_MESSAGE, T_AUTHOR, T_REPLIES, T_UREPLIES, T_VIEW_COUNT, T_LAST_POST, T_DATE, T_LAST_POSTER, T_IP, T_LAST_POST_AUTHOR, T_LAST_POST_REPLY_ID, T_ARCHIVE_FLAG) VALUES(1, 1, 1, '0', 'Welcome to Snitz Forums 2000', 'Thank you for downloading the Snitz Forums 2000. We hope you enjoy this great tool to support your organization! Many thanks go out to John Penfold <asp@asp-dev.com> and Tim Teal <tteal@tealnet.com> for the original source code and to all the people of Snitz Forums 2000 at http://forum.snitz.com for continued support of this product.', 1, '0', '0', '0', '20100129052717', '20100129052717', '0', '000.000.000.000', 1, 0, 1)
Error: -2147217865 [MySQL][ODBC 3.51 Driver][mysqld-5.0.67-log]Table 'genesisforumitalia.FORUM_TOTALS' doesn't exist
strSql: INSERT INTO FORUM_TOTALS (COUNT_ID, P_COUNT, T_COUNT, U_COUNT) VALUES(1,1,1,1)

The Installation has NOT been completed !

There were 13 Critical Errors...

Click here to retry....

Click here to check the Database....

Edited by - marckmcgill on 29 January 2010 05:30:34
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 29 January 2010 :  07:04:21  Show Profile  Send ruirib a Yahoo! Message
Ok, let's see if a more comprehensive reply comes out now.

You will need to distinguish between autoincrement fields and non autoincrement fields. For autoincrement fields, you need to remove the DEFAULT clause. For integer fields, non auto increment, make sure the default value is not a text value, that is, instead of DEFAULT '0', use DEFAULT 0, for DEFAULT '1' use DEFAULT 1.


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 29 January 2010 :  09:47:28  Show Profile
Okay, thanks, will give it a new try on monday. Thank you so far.
Go to Top of Page

Davio
Development Team Member

Jamaica
12217 Posts

Posted - 29 January 2010 :  10:18:26  Show Profile
You are going to have problems running Snitz version 3.4.03 on mysql server 5. The errors you get with installation is going to be just the beginning of your problems.

We have made numerous fixes since then to make the forum compatible with the changes in the mysql server.

So you probably will have to upgrade your snitz forums to the latest version, or use an older version of the mysql server.
Or you can do all the various fixes by hand, as you run into the errors. This is on top of the difficult task of migrating from access to mysql as well.

Support Snitz Forums
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 11 February 2010 :  02:50:30  Show Profile
Dear Davio, first of all let me say clearly that we all appreciate the work you (the team) are doing and have done in the past. If we're here it is because we all liked the idea of having a forum, and Snitz gave us the possibilty to have one for free when this was a rare opportunity.

However, as already debated many times by other people in other threads, mostly receiving irritated and irritating answers by the developers team, Snitz experienced a bad lack of innovations in the past years, and the situation now is such that the basic software package may now be considered as obsolete. Some 5-6 years ago I remember reading answers to these kind of topics asking for innovations with sentences like this "well, THIS forum (the help community, I mean) doesn't have avatars but works very well". Okay. However, today, but even back then I must say, whoever subscribe to a forum EXPECT to have an avatar, to have the possibility of sending private messages, to check who is online at the moment, and so on. Administrators, on their own, NEED the possibility of editing the FAQ and adding new FAQs, and are in absolute need of an access control with IP check to block undesired users.

Back to topic, the reason why updating to a new install package is almost impossible is that most Snitz administrators sooner or later had the need to implement new functions via mod installations, and as we all know that installing a mod is a total nightmare, none of them is willing to pass through that nightmare again.

The reason why mods, I mean those felt as absolutely necessary (not idiotic gadgets), had neever been added to the forum package (obviously with the consent of the original writers) is quite a mistery and has been debated many times, and I'm not going through it again here although the answers I've read have always been unsatisfactory. Let me just add that this is the main reason why we initially tried to switch to WebWiz and then to PHPbb, eventually failed (both are likely impossible tasks, although some pretend they did), and thus decided we had to stick with good'ol Snitz.

So, back to the primary subject, may I ask you an educated opinion before taking a decision on which road shall we travel? Do you foresee as more painful going through all the problems that will rise from mySQL 5 and fix one after another, or instead restart from a fresh installation and add, say, 7-8 mods some of which hard-coded god only remembers where?

Thank you very much, I appreciate your help.
Go to Top of Page

HuwR
Forum Admin

United Kingdom
20584 Posts

Posted - 11 February 2010 :  04:44:38  Show Profile  Visit HuwR's Homepage
You could try setting up the latest version, then add any fields needed by your mods, import your current data and then blow away the current versions asp files and replace them with your older files. It may work and be a lot quicker. alternatively you could download a good file compare utility (beyondcompare) and compare your files with those in the latest release and move your mod code over it is generally a lot easier than you think.

If you think redoing your mods will be to big a job, send me an email and I may be able to do it for you.
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 25 February 2010 :  03:54:24  Show Profile
Okay, thank you for the reply. Sorry for delay but I'm working on this "conversion thing" when I have time and when I'm in the right mood.

I'm travelling the trail you suggested, hoping it works.

I did a fresh installation of the latest Snitz, which created the database without issues. However, the forum board seems to have a problem. The "Statistics" panel shows no data and reports this error:
Microsoft VBScript runtime error '800a000d'

Type mismatch

/default.asp, line 926

Is it something that has been addressed before?

I can't figure if we should fix it now or, as the software has however to be fully replaced with the older one in use on our forum, simply skip it and eventually fix it later in case it will still be there in the end.
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 25 February 2010 :  06:30:02  Show Profile  Send ruirib a Yahoo! Message
http://forum.snitz.com/forum/topic.asp?TOPIC_ID=69134&SearchTerms=default.asp,line,926


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page

marckmcgill
Junior Member

Italy
134 Posts

Posted - 26 February 2010 :  04:01:48  Show Profile
Thank you, I've read the topic. So what was the problem, in the end? The connection string perhaps?

My connection string is suggested by the host provider itself via a facility, so I assumed it to be correct by definition. It is as follows:


strConnString = "DRIVER={MySQL ODBC 3.51 Driver}; SERVER=highinfidelity.easycgimysql.com; PORT=3306; DATABASE=*******; USER=##########; PASSWORD=@@@@@@@; OPTION=3;" '## MySQL


Do you see any problem in it?
Go to Top of Page

ruirib
Snitz Forums Admin

Portugal
26364 Posts

Posted - 26 February 2010 :  04:26:26  Show Profile  Send ruirib a Yahoo! Message
You cannot assume anything, providers cannot always be trusted to know this stuff, as they don't run them, just host them. On the link I provided, there is a link to another post - this one: http://forum.snitz.com/forum/topic.asp?TOPIC_ID=55925. It has the fix and yes, it means you need to add something to the connection string - option=16387;


Snitz 3.4 Readme | Like the support? Support Snitz too
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Topic Locked
 Printer Friendly
Jump To:
Snitz Forums 2000 © 2000-2021 Snitz™ Communications Go To Top Of Page
This page was generated in 0.2 seconds. Powered By: Snitz Forums 2000 Version 3.4.07